MultiSite Activation Wizard – WMS II

I’m currently working on Multi Site Activation in a WMS II environment on AX2009, with the latest KR. Looks like there are some bugs – or at least, not all „real-life“ scenarios are covered in a useful way. Let me make quick notes on them, maybe it’ll help you, too:

  • Validation of WMSOrder

The validation code (InventSiteActivateCheck_WMSOrder.validate()) rejects all WMSOrders that have a from dimension with an empty inventory location. But at least in the WMSII case, these records are totally ok. Additionally, even if it was an issue, we still won’t mind if such an error exists on completed WMSOrders.

01WMSOrderValidation

  • Validation of WMSOrderTrans

Same reasoning for WMSOrderTrans (InventSiteActivateCheck_WMSOrdTrns.validate()), but add cancelled transactions to the „we don’t mind“ case.

02WMSOrderTransValidation

  • Multisite Readiness Report

This report (Administration > Reports > System) doesn’t work correctly, because their parameters are not handed over to the server execution. It’s easily fixed by adding the standard pack / unpack methods. To check whether your modification works, set a breakpoint in the report’s fetch method and verify that the inventSiteIdDefault and inventLocationIdDefault member variables are set as you specified in the Dialog.

Some more notes:

  • If you have custom inventDimID fields that need an udate, don’t forget to add them to the methods updateBatch and updateSequential of the InventSiteActivateUpdMgr class. (Yes, there is a hint in the Whitepaper, but …)
  • If you have custom Dimension fields on InventDim, add them to Table InventDimInsTemp.

Schreibe einen Kommentar

Deine E-Mail-Adresse wird nicht veröffentlicht. Erforderliche Felder sind mit * markiert.